Fokuseringsfrågor

Metoder för astrofotografering
magnuslar
Inlägg: 269
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Fokuseringsfrågor

Inläggav magnuslar » 2016-10-05 10:07:01

Hej!

Jag har några funderingar och frågor om autofokus. Mit set-up är:
Celestron C8
Meade focal reducer f/6,3
TS-optics crayfoord-fokuserare
Hemmabyggd Arduino-fokusmotor
Canon 350D kamera

Jag använder Ekos/Indi som system för att styra och hantera det hela, men jag tänker att mina frågor här inte direkt relateras till det.

Min frågor handlar om hur en autofokus-rutin bäst ser ut. Det jag är med om, är att autofokus kan ta så lång tid som 15 min, och eftersom Ekos fokuserar mellan de flesta exponeringar, så blir det få bilder av det. Dessutom tycker jag inte att fokus är så bra som jag skulle önska, och det är viss variation i vilket läge den landar på. (jag använder en toleransnivå på 5 % som man ställer in i Ekos, men jag måste erkänna att jag är oklar över vad det betyder - det beror väl på hur HFR-rutinen ser ut).

Min fokusrutin är att jag tar en 5-10 sek bild, på ISO 3200, och har ställt in Ekos på att ta 2 (ibland 3) frames och göra genomsnitt på HFR i dem. Det hela tenderar att resultera i ett diagram som inte har något alls med en V-kurva att göra, utan mer en svärm slumpmässiga punkter, som här:

v-curve.png
v-curve.png (14.72 KiB) Visad 1756 gånger


När jag byggde foksuerare räknade jag ut att jag borde ha ett fokusområde, givet fokallängd och fokuserarens egenskaper, som sträcker sig över 14 ticks (halvsteg med stegmotorn). I praktiken, när jag manuellt tickar mig genom ett längre område, verkar det som att jag får samma HFR över ett betydligt längre område, kanske 100 ticks, innan HFR börjar avvika med mer en en eller två tiondelar.

Varför blir det då ett sånt spridningsdiagram och inte en rak linje? Jag har tänkt att det beror på tillfälliga variationer, seeing mm. Det är därför jag kör med flera frames som den mäter genomsnitts HFR av. Alternativet är ju att ta längre exponeringstider, för att inte påverkas av det tillfälliga. Men borde inte 5-10 sek redan göra det?

Vad tänker ni andra om detta? Hur ser en välfungerande fokuseringsrutin ut, i överväganden om exponeringstid, tolerans, antal frames, osv?

Sen har jag en svag misstanke om att det som visar sig här kanske har att göra med min tubs begränsningar (jag kollimerar ofta, det borde inte vara den som spökar) men den rösten lyssnar jag inte på just nu - det låter dyrt....

Magnus
hbar
Inlägg: 421
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Fokuseringsfrågor

Inläggav hbar » 2016-10-05 12:54:22

Du har en rätt lång fokallängd även med reducerare (ca 1300) vilket borde ge dig ca 1.5"/pix. När jag sitter o försöker sätta fokus (där jag har mellan 0.5-0.8"/pix) så ser jag (även vid bra seeing) hur stjärnan dansar runt o ändra form ganska vilt (flera pixlar) vid 1 sek exp.

När du har 5-10 sek exp tid så kommer även tracking/vind mm in o spökar till det. Om vi tex låter detta ge en allmän "brus" nivå på motsvarande 5 och din optik klarar av att fokusera ner till 2 (vilket då skulle motsvara 14 ticks) så kommer systemet inte att se någon försämring förrän du är ur fokus motsvarande ~5 (viket kanske motsvara dina 100).

Tänk också på att alltid köra motorn åt samma håll så ev glapp inte ställer till det. Om din stegmotor driver c8ans fokus via huvudspegeln så har du också ett stort problem med mirror-flopp som gör att man inte vet var den hamnar när man för den fram o tillbaka.

Ett annat problem är om inte samma stjärna använd för fokusering mellan de olika tillfällena då du inte har ett helt plant bildfält (och förmodligen även en svag lutning).

Jag har en optec tcf fokuserare med Ted Argo reducer som du skulle kunna låna ett tag om du vill prova o se hur det funkar (den är använt på en c8 av Matts Sporre).

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
magnuslar
Inlägg: 269
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: Fokuseringsfrågor

Inläggav magnuslar » 2016-10-05 13:50:19

Hej!

Kanon, tack!
Det är inte C8-ans fokuserare jag kör på - det är för oprecist. Det är min TS crayfoord. Och den byter faktiskt inte stjärna, den håller ganska envist fast i en enda som den valt, så där ligger det inte.

Glapp i motorn - ja, det kan det ju vara. Det är också en Crayfoord så är alltid lite misstänksam på hur mycket "slir" det kan vara där, men när jag testar den verkar den fungera bra, utan slir. Autofokus byter håll.... det är svårt att påverka. Den kör fram och tillbaka...

Tänker du att det vore bättre att köra med kortare exponeringstider, som din 1 sek? Jag föreställer mig att hålla på och experimentera med detta ikväll, om vädret håller sig.

Och ja, jättesjysst, jag lånar gärna och testar...:) Din Optec är klart mer solid än min TS Optics.

Magnus
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Fokuseringsfrågor

Inläggav AstroFriend » 2016-10-05 15:07:40

Hej Magnus,
Jag kan ju beskriva mitt system och jämföra med ditt så kanske det ger någon ledtråd.

Jag har en refraktor på f/5.3 så inte så olikt ditt ur ljustyrkesynpunkt. Däremot är min fokallängd 680mm och din 1300mm.

Kameran är en Canon 6D, mindre brus och mindre pixlar.

De gånger jag autofokuserar gör jag det i APT och väljer HFR vilket fungerar mycket bättre än HWFM.

För att hålla nere bruset väljer jag starka stjärnor och ISO100 till 400 och 1 till 3 sekunder.

Väljer alltid stjärna i center av fältet.

Min kurva blir mer V formad än din men inte så bra som jag vill ha det.

Det jag inte är nöjd med är att jag skulle vilja fokusera på flera stjärnor för att få ned bruset men det klarar inte ATP.

ASCOM drivrutinen till fokus motorn kan ta glapp parametrar. Glappet brukar ligga på ca 20 steg och jag har matat in 30 steg. Fokuserar alltid åt ett håll, när jag (datorn) behöver backa så gör den 30 steg tillbaks och sedan framåt igen för att minimera glappet. Verkar fungera bra.

Steglängden när den fokuserar brukar jag i regel välja till 100 för grov eller 20 steg för fin.

Man får ju tänka på att det är en single sensor färgkamera. Så signalen varierar ju beroende på vilken färg pixlarna har. Egentligen kanske man skulle välja en lägre upplösning på kameran så den slår ihop pixlarna så detta problem försvinner, upplösningen lär räcka till i varje fall. Bilden den fokuserar på är jpg så på det sättet är det ju egentligen redan en interpolering gjord.

Här har jag skrivit om mitt fokusbygge:
http://astrofriend.eu/astronomy/project ... focus.html

Jag har ganska dålig seeing när jag gör detta och det kan ev. vara vibrationer från balkongen också som försvårar.

Fokusen blir inte perfekt men ganska bra och går på ett par minuter om jag börjar i nära rätt läge. Är ju ganska temperturberoende så ibland börjar jag i olika startpunkter. Det tar minst 30 minuter för att komma i temperaturjämviktsläge och innan dess ingen ide att fokusera. Den tiden använder jag för att kalibrera in pekningen med AstroTortilla.

Känns som om det i ditt fall är ganska brusigt och en Canon 350D vid ISO3200 innebär ju kraftig brusreducering i kameran men ändå så är bilden brusig. Stjärnor är ju väldigt ljusstarka och överexponerar i regel efter någon sekund även vid lägsta ISOtal. Visserligen är HFR ganska bra även med överexponerade stjärnor har jag läst, själv håller jag dock mig med betydligt lägre exponering.

Hoppas det var till någon hjälp.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
hbar
Inlägg: 421
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Fokuseringsfrågor

Inläggav hbar » 2016-10-05 15:10:55

Magnus, bra att du har en separat (annars hade det nästan varit hopplöst:).

Om jag skrev programmet själv så skulle jag ta flera korta och stacka (så ev positioneringsfel försvann) om s/n var för dåligt för en kort. Då skulle också seeing fluktuationerna medelvärdesbildas. Nu kan du väl inte göra så utan måste utgå från färdig programvara.

För att testa så kör på en ljusstark stjärna så du kan köra med 1 sek exp för att se hur det går. Försvinner problemet så är ju trackingen förmodligen det som är den stora störkällan.

Jag förmodar att du inte kör stegmotorn direkt på Crayfoord-friktions-axel. Driver du på den lilla planetväxeln (1:10) som brukar finnas så brukar dessa vara av väldigt dålig kvalité. Svårt att hitta Crayfoord fokuserare som är tillräckligt bra, Baader steelrack lär vara hyfsad i "lågpris" segmentet. Till min refraktor gav jag upp (ville klara tunga kameror) o byggde om den till rack & pinjon (har du fb så är där en bild där).

Jag kommer inte att anv tcf-n på ett bra tag så planera in en tur när du har tid. Den har serieport, om där är driver till ditt program så kan du förmodligen använda den direkt.

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Fokuseringsfrågor

Inläggav Lazze » 2016-10-05 18:54:33

Ibland är det väldigt svårt att se med blotta ögat om fokuseraren slirar lite men om man har ett fokuseringsprogram som ritar upp V-kurvor som FocusMax så ser man det väldigt tydligt när man kalibrerar. Gör man flera kalibreringskurvor ser man hur lågpunkten på "V"-et gradvis förskjuts i sidled om fokuseringen inte är helt stabil.
Nu känner jag inte till om fokuseringsprogrammen ni nämner använder sig av V-kurvor men det går fortfarande att hitta version 3 på FocusMax som är gratis.

Sen ett stalltips som många SCT-ägare använder sig av (om det inte är en Edge C8 du har) är att fokusera på en stjärna 1/3 ut från centrum när du väl fått allt att fungera. Det brukar ge skarpast stjärnor över hela bilden eftersom SCT:er brukar ha en del fältkurvatur som gör att stjärnorna närmare kanterna blir lite suddigare.

/Lasse
magnuslar
Inlägg: 269
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: Fokuseringsfrågor

Inläggav magnuslar » 2016-10-05 20:00:03

Hej!

Jo, jag har fokuseraren direkt på axeln, se här: viewtopic.php?f=22&t=11182&p=52424#p60412

Jag noterar att en del av spridningsbilden i diagrammet jag postade nog produceras av programmet, Ekos. Men det är ändå något oklart över det. När jag repeterar autofokus nu, ikväll, med 1 sek exponering, så landar den på olika värden med just upp till nästan 100 ticks skillnad. Men alltså samma HFR...

Magnus
hbar
Inlägg: 421
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Fokuseringsfrågor

Inläggav hbar » 2016-10-06 14:35:58

Hej Magnus

Eftersom du fick ung samma fördelning med 1 sek så kan det ju inte vara tracking fel som ställer till det. Seeingen är ju fortfarande en bov men kan inte förklara en så stor spridning.

När man mikrostegar en stegmotor så måste man tänka på att bara helstegen är någorlunda distinkta i positionen (+-1/2 steg beroende på belastning). Redan vid halvsteg så börjar motorn tappa positionsupplösning. Du har en planetväxel o axel-koppling. Här har du förmodligen ett glapp (under belastning) på några helsteg (~2-10 beroende på kvalitet).

För att en Crayfoord fokuserare inte skall slira så behövs rejält tryck och oftast så är materialet i tuben av mjukt aluminium. Även om det ligger en stålplatta mot axeln så ligger ofta mottrycksrullarna direkt mot tuben och kan lätt skära in i denna som du ser på den övre vänstra bilden. Jag ersatte dessa med två kullagerringar (för att också förhindra att tuben tilltar med en tung kamera). Innan var de bara de 4 små kullagerrullarna på plattan i mitten av bilden som höll emot.

Riktar du tuben uppåt så kameran belastar maximalt neråt och gör flera omfokuseringar så borde du som Lasse beskrev kunna se om fokus området glider. Gör det inte det så kan kanske Robert lägga in i Arduinon en lämplig glapp kompensering genom att den går ett antal steg extra när riktningen ändras.

/Håkan

wofok.jpg
wofok.jpg (324.11 KiB) Visad 1622 gånger
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Fokuseringsfrågor

Inläggav AstroFriend » 2016-10-06 17:08:24

Hej Håkan,
Vilken imponerande mekanik, har något liknande själv men hittills inte haft något problem med att kullagren grävt sig in i metallen, men det kanske kommer för det är hårt anspänt för att klara kameratyngden. Var fick du tag i kullagerringarna?

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
hbar
Inlägg: 421
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Fokuseringsfrågor

Inläggav hbar » 2016-10-06 17:38:11

Hej Lars
Köpte lösa kulor o svarvade banorna själv. De har en spalt i toppen då järn o aluminium har olika utvidgningskoefficient. Nylon klossar som håller isär kulorna gör att jag kan ställa diametern så att tuben glider lagom trögt. Det lätta alternativet hade varit att köpa en Feather Touch focuser (de har färdiga för WO, de flest byter direkt) men de kostar $925... Köpte teleskopet beg av en avliden snickare med starka nypor:).

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
magnuslar
Inlägg: 269
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: Fokuseringsfrågor

Inläggav magnuslar » 2016-10-06 20:29:37

Hej!

Ja, det där såg riktigt seriöst ut...:) Här ligger man i lä....

Tyvärr är det lite svårt att experimentera ikväll, men jag hann meka lite. Jag har spänt åt axeln mot tuben, så kanske det gör skillnad. Men jag tänkte på att det ju inte bara är många steg som skiljer mellan olika slutresultat - det är ju samma HFR. Kan det vara så att jag har ett långt område, ca 100 ticks, som är ganska likt, men inget riktigt riktigt bra fokus? Jag är inte tillräckligt bra på optik för att kunna tänka om det. Men spontant känns det som att det kunde ju vara fallet...?

Jag menar: när jag manuellt stegar mig fram med 10 ticks i taget så får jag ett nästan platt område på i alla fall 50 ticks om inte mer - vilket inte riktigt känns som de där 14 som min beräkning sa.

Magnus
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Fokuseringsfrågor

Inläggav AstroFriend » 2016-10-06 20:49:35

Hej Magnus,
Hur beter det sig när du exponerar på ljusstarka stjärnor och mer normala ISOtal och korta exponeringar?

Med dom inställningar du har om jag hade använt de på min gamla Canon 5D hade inte autofokus fungerat och 5D är väldigt lik 350D, jag har haft båda kamerorna.

50000 steg på min fokuserare ger 80mm och det är helsteg, har aldrig provat att mikrostega den. Satte en kuggremsväxel mellan motor som har inbyggd växellåda och den direktdrivna axeln på fokuseraren. Jag har också kompletterat med ett stabiliseringsstag till fästplattan för motorfästet då det kunde märkas en aning flex där. Och som sagt mycket hårt åtdragen axeltryck mot stålskenan.

Håkan,
Jättefint bygge, imponerad!

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
hbar
Inlägg: 421
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Fokuseringsfrågor

Inläggav hbar » 2016-10-06 20:52:53

Jag fick aldrig veta om du använder halvsteg/mikrosteg. Din motor har väl 200 helsteg per varv, hur många ticks är detta?

Om vi sätter position 0 till mitten så ditt 100 ticks område är pos +-50. Om du då går manuellt från tex -200 (så att du kan upphäva ev glapp i växel de första 100 ticksen) och fram till +100. Har du då fortfarande ett område på ca -50 till +50 där ditt hfr ligger mer eller mindre konstant?

Om så är fallet så behöver man nog titta på några bilder från pos -40, 0 resp +40 så det går att se om där är någon form av osymmetri i bilden (liknande astigmatism).

Mina insatser i verkstaden är helt amatörmässiga, bilderna är i låg upplösning:).

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
magnuslar
Inlägg: 269
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: Fokuseringsfrågor

Inläggav magnuslar » 2016-10-06 21:41:51

Hej!

Det finns grader av amatörmässighet.....:)

Halvsteg - men det är en planetväxel 5:1 på den (NEMA17-PG5). 1036 steg per varv. Så 2072 halvsteg per varv. Allt enligt beräkningar jag gjorde när jag byggde, enligt Roberts instruktioner.

Bra plan det där. Ska bara bli av med molnen så kör jag så.

Magnus
magnuslar
Inlägg: 269
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: Fokuseringsfrågor

Inläggav magnuslar » 2016-10-08 10:36:32

Hej!

Nu har jag testat lite mer, mellan molnsjoken. Jag har först kört autofokus några gånger, som landar mellan 1140 och 1190 ungefär. Sen har jag kört en manuell serie från lägre till högre värden, mätt och sparat bilden för var 10:e tick från 1100 till 1250. Bilderna finns som fits i mappen fokus i min dropboxmapp:

https://www.dropbox.com/sh/fs744ujp8oed ... 2dUBa?dl=0

Bifogat en pdf med hela resultatet inklusive bilder i png-format. De är stretchade i PI med samma stretchinställning. På en del ställen mätte jag flera gånger men inte alla.

Vad kan man tänka om detta?

Magnus
Bilagor
fokus.pdf
(100.96 KiB) Nerladdad 38 gånger

Återgå till "Metoder & bildbehandling"

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst