PixInsight-problem

Metoder för astrofotografering
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

PixInsight-problem

Inläggav dragneg » 2019-04-26 19:31:29

Hej.

Jag har ett problem med PixInsight som bara dyker upp ibland. Fram till och med integrering kör jag alltid ett och samma flöde. Ibland blir bakgrunden väldigt jämn och fin men ibland kan man tydligt urskilja brus i 45-graders vinkel. Finns här någon som känner igen fenomenet?

I jpg-format går det förmodligen inte att se så tydligt, så jag länkar underst till Tiffar i min Dropbox om någon har tid och lust att ta en titt.

M51 noise.jpg


M13 noise.jpg


Bägge motiven är tagna med en Celestron EdgeHD 8” f/7 och en ZWO ASI294MC Pro. M51 är tagen med ett Hutech IDAS LPS-P2 medan M13 är tagen med ett Baader UV/IR-cut.

M51 består av 233x180sek + 89x120sek. Totalt 322 bilder på sammanlagt 14tim37min över fyra nätter. Dithering användes mellan de flesta men inte alla bilderna. Bilden är nystackad och croppad med en STF och strechad.
M13 består av 582x60sek. Totalt 9tim 42min över tre nätter. Ingen dithering mellan bilderna, i övrigt samma som M51.

Samma MasterDark och SuperBias har använts. Däremot ”egna” MasterFlats gjorda med samma LED-panel. Sensortemp var samma, -20.

Man kan se en enorm skillnad på bakgrunden. Medan M51:an är väldigt jämn ser M13 ut att ha ett 45-graders mönster. Jag vill mena att jag har tidigare lyckats få både jämn bakgrund med färre bilder, timmar, utan dithering och mönstrad bakgrund med fler bilder, timmar och dithering. Jag har därför svårt att tro det bara handlar om dithering, men jag kan inte för mitt liv begripa vad annat.



Ytterligare en märklig detalj som jag stötte på... Jag testade för första gången att vikta de 582 bilderna efter FWHM, SNR och ECCENTRICITY i SubframeSelector.
M13-bilden ovan är viktad som bilden på M51 med Noise evaluation. M13 nedan är viktad med ”FITS keyword” från SFS enligt ovan.
I den översta M13 kan man, förutom mönstret i 45 grader, se att bakgrunden är mest grå. I M13 nedan kan man urskilja en tendens till färgade band, eller ”vågor av färg” i 45-gradersmönstret. Stjärnorna förefaller dock något skarpare...

M13 SFS FITSkw.jpg


Tacksam för idéer


Tiffar: https://www.dropbox.com/sh/8w1n4xxfkh9o ... SO0da?dl=0

/anders
Nexstar 8SE, EdgeHD 8", EdgeHD 11", Esprit100ED, iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
kribba
Inlägg: 704
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-04-26 20:07:14

Jo jag har tidigare haft problemet oxå med både Canon kamera och ASI1600MC. Fattar inte heller varför det dyker upp ibland men
inte andra tillfällen. Så mycket har jag kopplat att det antagligen har med om man kör oguidat färg och kalibrerar med dark,bias.
Har inte upplevt det när jag guidat med full kalibrering. Men har du kört dithering så verkar det konstigt?
Det är väl därför mono is the skit :D
Finns en del trådar om detta på CN oxå, i synnerhet med Canon kameror.
Kommande SDST i Extremadura Spanien. Blandade teleskop, kameror och monteringar hemmavid.
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-04-26 20:18:16

Jo, jag använder oftast dithering. Men när exponeringstiden är kort så tycker jag att för många procent av mörkret försvinner. Det tar ofta upp till en minut att ”dithra” och med 60sek exponeringar så är det för mycket. Vid långa exponeringar spelar det ju mindre roll. Därför är den bifogade M13 utan dithering. På M51 körde jag lite både-och, där var det ju tre-minuters exponeringar som mest.

Jag guidar alltid och på båda bilderna, M51 och M13, har guidingen varit helt fantastisk.

Märkligt är det...


https://flic.kr/p/2e9Ma6K



/anders
Nexstar 8SE, EdgeHD 8", EdgeHD 11", Esprit100ED, iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
SvenP
Inlägg: 59
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-04-26 22:44:03

Jag har sett samma fenomen på bilder som jag tagit med min ASI294 MC pro. Vad beträffar 45-gradersstrukturerna tror jag det beror på felaktig kalibrering.
På ZWO.s hemsida lärde jag mig att man måste kalibrera med en masterdark som har framställts med darks vilka har exakt lika lång exponeringstid som ligths (och samma gain och temp). Man kan inte använda sig av en masterdark baserad på darks med längre exponeringstid och inte använda sig av "Optimize" i PI "Imagecalibration".
Vidare ska ingen BIAS-kalibrering ske.
Sedan jag gjort kalibrering enligt ovan har jag inte märkt av något 45 graders mönster i mina bilder.
När de gäller de mer färgglada strukturerna i bakgrunden så dyker de upp speciellt då förhållandena inte är så bra. T.ex. snötäcke som reflekterar stads- och gatuljus mm upp i diverse föroreningar i atmosfären. Det ser då ut som bilderna inte tål så mycket stretch. Som default i PI STF är "target background" satt till 0,25 men jag brukar kunna dra ned detta till 0.1 utan att förlora detaljer men däremot få betydligt mindre färg och brus i bakgrunden. Vidare tycks det också hjälpa bra att minska lite på "shadows clipping" i STF. Slutligen så har jag också märkt betydande förbättringar genom att göra ABE eller DBE på resp kanal, d.v.s splitta RGB-mastern göra ABE eller DBE på gråskalebilderna och därefter kombinera dessa till en ny RGB-master och därefter göras ännu en ABE eller DBE.

/SvenP
Användarvisningsbild
kribba
Inlägg: 704
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-04-27 07:20:43

Bra tips Sven!
Men om man struntar i bias, måste man kalibrera manuellt
då eller funkar det även med BPP scriptet ?
Kommande SDST i Extremadura Spanien. Blandade teleskop, kameror och monteringar hemmavid.
SvenP
Inlägg: 59
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-04-27 10:05:33

Jag använder inte BPP utan kör manuellt. Men så vitt jag kan se så går BPP att använda. Det är bara att låta bli att ladda Bias, unchecka "Optimize" i Dark-fliken etc
(jag är dock osäker på om "Optimize" tillför eller tar bort något då man använder darks som inte ska "skalas" och inte använder Bias, jag har inte undersökt detta närmare)
Jag vill betona att mina tips inte grundar sig på tekniska kunskaper utan på instruktioner från ZWO och kamerasäljaren som jag haft en hel del kommunikation med. Tvärtom så stämmer kalibreringsrutinerna som ZWO anger på sin forumsida inte med vad som t.ex. framställs i astrofotobibeln "The Handbook of Astronomical Imageprocessing" men å andra sidan börjar den boken bli lite gammal och behandlar i huvudsak monokroma CCD-sensorer.
Min erfarenhet är också att om man inte använder dithering så bör man köra "cosmetic correction" i PI för att bli av med lite färgglada pixlar. Cosmcorr hjälper dock inte mot färgglada bakgrundsgradienter.

/SvenP
Användarvisningsbild
kribba
Inlägg: 704
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-04-27 13:11:15

Tack, ska testa på ngn gammal problembild. Jo har läst trådar på CN där folk verkar också strunta i Bias, så du verkar inte ensam.
Kommande SDST i Extremadura Spanien. Blandade teleskop, kameror och monteringar hemmavid.
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-04-27 15:17:29

Tack Sven. Den artikeln på ZWO hade jag inte läst. Intressant... Jag skall testa utan BIAS, även om jag inte förstår varför. Darks tagna vid rätt temperatur och med rätt exponeringstid har jag, men jag har använt ”Optimize”...

Men det är fortfarande märkligt. Min PI-workflow, fram till och med integrering, bygger på förinställda Process icons, så att alla Flats och Lights görs på samma sätt varje gång. Blink, Calibration, Cosmetic Correction, Debayer, SubframeSelector, StarAlignment, Integration. Så ur den synvinkeln är mina M51 och M13 ovan gjorda exakt lika, med både BIAS och Optimize av Darks.

Däremot är jag mycket osäker på hur STF ställs in och har därför endast använt default med okopplade kanaler. Att olika mörk himmel kan behöva olika stretch har jag inte haft en tanke på och i så fall är det ju det som skiljer mina bilder åt! 45-gradersmönstret måste ju däremot vara ren matematik och en för tillfället korrekt stretch kanske döljer det, medan en ”felaktig” tar fram det?

Jag skall testa dina råd ovan. Det var exempelvis mer månljus under fotandet av M13 än M51, även mer fukt i luften.



Kribba, är det ”Canon Banding” du menar? Det har jag med läst en del om på CN. Jag har också sett det någon gång på bilder från min EOS700D. Att det bara uppstår ibland skulle väl även där kunna bero på STF-inställningar som inte matchar de olika ljusföroreningarna de olika nätterna...


/anders
Nexstar 8SE, EdgeHD 8", EdgeHD 11", Esprit100ED, iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Martin F
Inlägg: 1696
Blev medlem: 2013-11-06 12:16:53
spamtest: JA

Re: PixInsight-problem

Inläggav Martin F » 2019-04-27 15:31:33

Även jag har märkt att det inte funka med skalning eller optimering av darks (har Asi 1600MM-Cool). Måste vara samma exponering.

Skickat från min E5823 via Tapatalk
magnuslar
Inlägg: 323
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-04-27 19:54:29

Hej!

Jättebra att du tar upp det här - jag har upptäckt nåt som ser ut att vara precis samma fenomen - mörka stråk i 45 graders vinkel - i en del av mina subs från min nya (begagnade) Atik 383l+. Jag trodde först det var nåt fel med kameran men nu förstår jag det är nåt annat. Jag har bara hittills sett det på vissa subs (OIII, inte Ha). Och det är alltså en monokrom kamera.

Tyvärr har jag ännu inte så mycket att bidra med i tolkningen av det, men har du testat att fråga på Pixinsight-forum? Kalibrering I PI är ju lite speciell, som jag förstår det - bland annat det där med att inte kalibrera master dark med bias, utan sen köra med "Calibrate" checkat vid kalibreringen av lights. för nånting med kalibrering verkar ju detta vara men varför det skulle bli såna sneda stråk, det verkar ju svårt att förstå. Men kanske nån PI-guru kan säga nåt om det, tänkte jag...?

Mvh

Magnus
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-04-30 23:46:12

Jag har stackat bilder hela kvällen och kommit fram till...nästan ingenting.

Så länge jag begränsar mig till en och samma session, så slipper jag strecken i 45gr vinkel, men så fort jag blandar en, två eller tre nätter så syns de.

De sju bilderna nedan visar det stackade resultatet av de 625st 60sekunders jag tog under tre nätter, i olika kombinationer enligt texten på bilden. Direkt efter färdig Integration har jag endast croppat bort dåliga kanter och applicerat en standard STF.
Alla sju bilderna är gjorda på exakt samma sätt och tillsammans, fram till och med StarAlignment. Darks är inte Optimized. Alla sju använder samma bild för StarAlignment och Integration, vilket är den bild som ”vann” viktningen i FWHM, Eccentricity samt SNR, en bild från andra natten.

Kan det uppstå interferens mellan ”bild-serierna” bara för att dithering till största delen inte användes under dessa tre nätters fotograferande? Varför skulle den i så fall visa sig lika vid alla fyra kombinationerna och varför inte inom en och samma kväll?

Vanligtvis tycker jag det går alldeles utmärkt att kombinera flera olika sessioner. Exempelvis är min M51 ovan kombinerad av fyra nätter. Visserligen bara hälften så många bilder som den randiga bilden på M13 men fyra timmar mer intergrerat samt att dithering användes, annars är det inget som skiljer dom åt i teknik eller utrustning...

/anders




M13_PI.JPG
Nexstar 8SE, EdgeHD 8", EdgeHD 11", Esprit100ED, iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
MartinS
Inlägg: 208
Blev medlem: 2016-06-26 13:33:40
spamtest: JA

Re: PixInsight-problem

Inläggav MartinS » 2019-05-01 10:05:08

Fasen va tråkigt med dessa problem. Har du kört exakt samma STF stretch över alla bilder? När ditt SNR går upp skulle man kunna tänka sig att PI kan göra auto stretch lite hårdare och på så vis så kan strecken dycka upp.

Kan det vara så att finns där hela tiden men inte syns för att mönstret döljs av shot noise?

Borde ju förvisso tas bort av darks..

Edit: Du har ju använt dithering kom jag på. Då kan det ju rimligtvis inte ja med kameran att göra. Riktigt skumt.
SvenP
Inlägg: 59
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-05-01 12:51:25

Jag kan inte hitta mina bilder där dessa diagonala föroreningar dök upp för att ev kunna se vad som kunnat orsaka dessa i mitt fall.
Så vitt jag förstår av dina bilder blir det bra om du integrerar varje session var för sig emedan diagonalerna börjar dyka upp vid integrering av två sessioner och blir värst vid integrering av alla tre.
Det är ju ett enormt bildmaterial du har så jag föreslår att du experimenterar med kanske bara 15 subbar från varje session för att se om fenomenet består.
Det enda jag kan komma på annars är att det har något att göra med med rutinerna för "Normalization" eller "Weights" i integreringsmodulen.
Hur man kan hantera "weights" framgår av en instruktion här på forumet, se länk
viewtopic.php?t=17906.
I övrigt skulle jag, i förekommande fall, pröva med att ta bort subbar med överdrivet högt och lågt SNR


/svenP
magnuslar
Inlägg: 323
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-01 17:04:17

Hej!

Här är en bild där mina diagonala streck dyker upp, mer för att visa att du inte är ensam. Det här är OIII, integrerad av subs från flera nätter. Exakt samma process på Ha-subs visar inga såna diagonala streck. Jag använder inte BPP utan gör allt manuellt, med olika flats för varje natt och för varje filter, men samma bias och darks. Jag kör med Calibrate iklickat på darks, master dark tillverkad utan bias (följer PI-instruktionen från sajten och från boken).

Jag har lite svårt att förstå hur detta skulle kunna skapas av dithering, men jag har använt dithering här. Varför just den här lutningen på strecken, och varför på OIII men inte Ha-subs...?

Jag har lite väl mycket jobb just nu så hinner inte gräva i detta, men återkommer när jag får mer tid.

Bilden jag skickar med är strechad och croppad bara för att visa detta.

Mvh

Magnus
Bilagor
OIII_drizzle_integration_2019-04-17_r_stretched_cropped.png
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-01 18:11:53

Även mitt PI-flöde kommer mer eller mindre direkt ur boken ”Inside PixInsight” och jag har betydligt fler lyckade bilder än med denna typ av störning. Inte heller jag använder BPP utan kör manuellt.

För att förtydliga så använde jag inte Dithering under de tre kvällarna, mer än mellan några få bilder, eftersom den tog nästan lika lång tid som själva subben (60sek) och därmed nära skulle halverat antalet möjliga bilder. Jag tänkte att mängden bilder och bra Darks lätt skulle kompensera avsaknaden av Dithering. ”Kul” att nu se Magnus bild med precis samma problem, fast MED Dithering.

Jag provar just nu Svens råd och stackar lite färre. Var nyss klar med 60 bilder från varje kväll, totalt 180bilder, vilket resulterade i precis samma fenomen som tidigare.

Testar nu vidare med och utan sånt jag kan hitta på, såsom med och utan Weighting.

Jag har haft några sessioner under senaste 18 månaderna, där resultatet av hittills outgrundlig anledning uppvisat ett mkt tydligt och svårbemästrat brus. Jag skall studera dessa lite närmare och se ifall det egentligen är samma problem i grunden.

I och med att jag använt mig av i stort sett samma flöde ända sedan jag köpte PixInsight för ett drygt år sedan, så tycker jag att det vore märkligt om det skulle ligga ett ”fel” där som orsakar streck bara ibland.

Svens och Martins tips om STF, att olika bilder inte tål lika mycket stretch och att autostretch blir ”fel” är jätteintressant...



Jag stackar vidare mot än så länge okända mål... /anders
Nexstar 8SE, EdgeHD 8", EdgeHD 11", Esprit100ED, iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D

Återgå till "Metoder & bildbehandling"

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst